Rows are not collapsable

General issues related to the use of Metro 4
Post Reply
Autoflow
Posts: 9
Joined: Thu Jul 11, 2019 7:17 pm
Status: Offline

Rows are not collapsable

Post by Autoflow » Tue Jul 30, 2019 8:21 pm

Hi,
rows are not collapsable cause of property display:flex and js checking for "block".
Perhaps this can be fixed in a future release.

Best regards,
Alexander

User avatar
olton
Site Admin
Posts: 233
Joined: Mon Apr 09, 2018 6:19 pm
Location: Kiev, Ukraine
Status: Offline

Post by olton » Tue Jul 30, 2019 8:27 pm

In Metro 4 (4.2.x) for collapse used jQuery methods slideIn, slideOut. These methods do not support elements with property display different from the block. This not a problem Metro 4. In 4.3.x Metro 4 use own library for DOM manipulation and elements animation - m4q. slideIn, slideOut in m4q support any types of display property, not only block.

Autoflow
Posts: 9
Joined: Thu Jul 11, 2019 7:17 pm
Status: Offline

Post by Autoflow » Tue Jul 30, 2019 8:45 pm

Thank you very much olton.
Will be looking forward to official 4.3 release :-)

User avatar
olton
Site Admin
Posts: 233
Joined: Mon Apr 09, 2018 6:19 pm
Location: Kiev, Ukraine
Status: Offline

Post by olton » Tue Jul 30, 2019 9:38 pm

For 4.2.x you can use wrapper

Code: Select all

<div data-role="collapse">
    <div class="row">...</div>
</div>

Post Reply